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Auto-Drilling Tutorial 

 

Introduction 

Auto Drilling is intended to ease the creation of hole-making sequences and to reduce the 

time required to program the tool paths.  This will be accomplished through the use of a 

new interface which will allow the programmer to create multiple NC hole-making 

sequences from one dialog box with a minimum of picks.  Auto Drilling will 

automatically create the NC hole-making sequences, on holes chosen by the user, by 

referencing the information in an appropriately assigned Manufacturing UDF.  This will 

all take place from within one table/dialog box.  Once created, the NC sequences can be 

edited manually through standard Pro/NC methods. 

 

Creating NC Sequence 

All of the files for this tutorial are attached. 

Retrieve the file, part_1.prt, part_2.prt, part_1_wp.prt, part_2_wp.prt and save them in a 

new folder. Then go to New > Manufacturing > NC Assembly, give the file name 

PART_1. Click OK. 
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 Step 1. Assembly part_1 and part_1_wp (part and its workpiece)  

MANUFACTURE > Mfg Model > Assemble > Ref Model 

 

Select part_1.prt, then click Open. 
 
Assemble > Workpiece, select part_1_wp.prt, then click Open 
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Assemble part_1 and part_1_wp. (See Pro-e ‘assembly tutorial’ for detail)   
 Step 2. Manufacturing Setup 
 

 

After assembly, click Done/Return, then Mfg Setup 

For choosing machine, click the icon right to NC Machine 

 

Select Mill, 3 Axis, and keep other contents as defaults, then click OK 
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For creating programming zero, click icon right to Program Zero 

Creat > Pick, then pick workpiece 

3Planes > Done > Plane > Pick 
 

  
 Reorient your assembly as the above window shows, then pick left, front and top plane 
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Using Next and Reverse to choose and reorient X,Y, Z axis, Let X pointing right and Y 

pointing back just same as the above figure shows. The selected axis is in color red, when 

it is oriented correctly, click the corresponding axis. CS1 is created. 

 

For creating retract plane, click icon right to Retract surface, then Retract Surface 

Options box comes. Click Create Plane > Offset > Pick 
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Pick the top surface of the work-piece 

 

 

Then click Enter Value, put 0.5 then Enter, then Done 

Click OK in the Retract Surface Options box 

Put 0.01 for the tolerance, then click OK in the Operation Set Box  

 

Then click Tooling > MACH01 

Tool Setup box comes, create all of the tools as the following figures shown. 
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After setting up the 7 tools as the above windows shown, click Done from File menu  

Done/return from MFG SETUP box 

 

 Step 3. Creating NC Sequences 

Sequence #1 

MANUFACTURE > Machining > NC Sequence > Hokemaking > Done 
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Then Drill > Standard > Done 

Check Tool, Parameters and Holes, then Done,  Tool Setup box comes now. 

Select Tool #7, center-drill, then Done from File Menu 

 

Click Set,   

Then set up the parameters as above, click Exit from File menu 

Click Done from MFG PARAMS menu, HoleSet window comes now. 
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Click Add, then pick Axis A1 (most left one) then Done Sel, (using Query Sel, if 

necessary) 

Click Depth, check Blind for Hole Depth 

 

Check Surface for Start Surface, click Select, click top surface of the workpiece 

Check Z Depth for End surface, put 0.25 

Click OK, in the Hole Set Depth box, click OK in the HoleSet box. 

 

Click Done/Return > Play Path > Screen Play, then click ‘play’ button in the PLAY 

PATH box, adjust play speed if necessary. Close the PLAY PATH box. Click Done Seq 

in NC SEQRENCE menu 
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Sequence #2: 

Then click NC Sequence > New Sequence > Holemaking > Done 

Drill > Standard > Done 

Check Parameter and Holes only, Then Done 

Click Use Prev, click Sequence #1 in NC SEQ LIST, then Done 

Then Axes > Add, select Axis A2 and A3, Done Sel 

Click Depth, check Blind, for Start and End Surface, same as previous sequence. Then 

OK in the Hole Set Depth box, OK in the Hole SetBox 

Done/Return > Play Path , close the Play Path box, then click Done Seq. 

 
Sequence #3: 
NC Sequence > New Sequence > Hole Making > Done  

Drill > Deep > Constant Peck > Done 

Check Tool, Parameters and Holes, and then Done 

Select Tool #1 (1/2 inch drill) and the Done from File menu 

Use Prev, then click sequence 2 

Click Set in MFG PARAMS menu 

 

Then change PECK_DEPTH to 0.5 and keep other values, click Exit from File menu 

Then Done from MFG PARAMS menu. HoleSet box comes now. 

Click Axes > Add, select A1 axis, Done Sel, then click OK in the Hole Set box 

Then Done/Return in the HOLES menu 
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You can play the tool path now, then Done Seq in NC SEQUENCE menu 

 

Sequence #4: 

NC Sequence > New Sequence > Holemaking > Done 

Drill > Standard > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #2 (1 inch  drill), then Done from File menu 

Use Prev in MFG PARAMS menu,  click NC sequence #3 under NC SEQ LIST 

Then click Done in MFG PARAMS menu,  

Axes > Add in Hole Selection box, select axis A1, then Done Sel 

OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

Sequence #5: 

NC Sequence > New Sequence > Holemaking > Done 

Ream > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #3 (1.125 inch ream), then Done from File menu 

Use Prev in MFG PARAMS menu, click NC sequence #4 under NC SEQ LIST 

Then click Done in MFG PARAMS menu,  

Axes > Add in Hole Selection box, select axis A1, then Done Sel 

OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

Sequence #6: 

NC Sequence > New Sequence > Holemaking > Done 

Drill > Standard > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #5 (0.75 inch  drill), then Done from File menu 
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Use Prev in MFG PARAMS menu, click NC sequence #3 under NC SEQ LIST 

Then click Done in MFG PARAMS menu,  

Axes > Add in Hole Selection box, select axis A2, then Done Sel 

OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

Sequence #7 

NC Sequence > New Sequence > Holemaking > Done 

Countersink > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #4 (countersink), then Done from File menu 

Use Prev in MFG PARAMS menu,  click NC sequence #6 under NC SEQ LIST 

Then click Done in MFG PARAMS menu,  

Check Auto Chamfer, then axis A2 and A3 are automated selected, because they have 

chamfer feature. Click on A3 and then Delete, keep A2 only 
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OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

Sequence #8: 

NC Sequence > New Sequence > Holemaking > Done 

Drill > Standard > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #1 (0.5 inch  drill), then Done from File menu 

Use Prev in MFG PARAMS menu,  click NC sequence #3 under NC SEQ LIST 

Then click Done in MFG PARAMS menu,  

Axes > Add in Hole Selection box, select axis A3, then Done Sel 

OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

Sequence #9: 

NC Sequence > New Sequence > Holemaking > Done 

Countersink > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #4 (countersink), then Done from File menu 

Use Prev in MFG PARAMS menu,  click NC sequence #7 under NC SEQ LIST 

Then click Done in MFG PARAMS menu,  

Check Auto Chamfer, in Hole Selection box, then axis A2 and A3 are automated 

selected, because they have chamfer feature. Click on A2 and then Delete, keep A3 only 

OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

 

 



Auto-Drilling tutorial 

   16 of 27 

Sequence #10: 

NC Sequence > New Sequence > Holemaking > Done 

Tap > Fixed > Done 

Then check Tool, Parameters and Holes in the SEQ SETUP menu, click Done 

Select Tool #6 (Tapping), then Done from File menu 

Use Prev in MFG PARAMS menu,  click NC sequence #9 under NC SEQ LIST 

Click Set in MFG PARAMS menu, change THREAD FEED to 5, and keep others 

Then Exit from File menu 

Then click Done in MFG PARAMS menu 

Axes > Add in Hole Selection box, select axis A3, then Done Sel 

OK in Hole Selection box 

Done/Return in HOLES menu, then you can play the tool path 

Done Seq in NC SEQUENCE menu 

 

 
We finished all of the NC sequence, it is ready to create MUDF (manufacturing user 

defined feature) 

 
 
Creating MUDF 
 
 MUDF #1: 
Machining > Utilities > UDF Library > Create, give MUDF name center-drill, then 
enter 
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Stand Along > Done  

 
 

 

 

 

Click NC Sequence, check NC sequence #1, Done Sel 
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Click Done Sel in NC SEQ LIST menu  

Click Done Sel in GET SELECT menu 

Click Done in SELECT FEAT menu 

Click Done/Return in UDF FEATS menu 

Click Single in Prompts menu, then Done/Return 

For prompt, enter 

‘operation’ for [operation] 

‘oper_csys’ for [coordinate system] 

‘oper_retract’ for [retract surface] 

‘axis’ for [axis] 

‘start_surface’ for [start surface] 

(Check Single and click ‘enter’ after each prompt) 

(Very important notice: the words entered for prompt must be exact same as the aobve) 

Click Done/Return in SET PROMPT menu 

Click OK in UDF setting table 

 

 

 MUDF #2: 

In UDF menu click Create, give MUDF name drill_1, then enter 

Stand Along > Done  

Click NC Sequence, check NC sequence #3, #4, #5, Done Sel 

Click Done Sel in NC SEQ LIST menu 

Click Done Sel in GET SELECT menu 

Click Done in SELECT FEAT menu 
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Click Done/Return in UDF FEATS menu 

Click Single in Prompts menu, then Done/Return 

For prompt, enter same words as MUDF#1 

Done/Return in SET PROMPT menu 

Click OK in UDF setting table 

 

 MUDF #3: 

In UDF menu click Create, give MUDF name drill_2, then enter 

Stand Along > Done  

Click NC Sequence, check NC sequence #6, #7, Done Sel 

Click Done Sel in NC SEQ LIST menu 

Click Done Sel in GET SELECT menu 

Click Done in SELECT FEAT menu 

Click Done/Return in UDF FEATS menu 

Click Single in Prompts menu, then Done/Return 

For prompt, enter same words as MUDF#1 

Done/Return in SET PROMPT menu 

Click OK in UDF setting table 

 

 MUDF #4: 

In UDF menu click Create, give MUDF name drill_3, then enter 

Stand Along > Done  

Click NC Sequence, check NC sequence #8, #9, #10, Done Sel 

Click Done Sel in NC SEQ LIST menu 

Click Done Sel in GET SELECT menu 

Click Done in SELECT FEAT menu 

Click Done/Return in UDF FEATS menu 

Click Single in Prompts menu, then Done/Return 

For prompt, enter same words as MUDF#1 

Done/Return in SET PROMPT menu 

Click OK in UDF setting table 
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Click Done/Return in UDF menu 

Click Done/Return in MACHINING menu 

 
 
Now four MUDF are done for future use. 

Save your file and close window. 

 

Auto-Drilling 

Step 1. Manufacturing Setup: 

Click New, check Manufacturing > NC Assembly, give file name: part_2, then OK 

Retrieve part_2.prt and part_2_wp.prt and assembly them. 
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Click Mfg Setup, then operation setup window comes, put OP_PART2 for operation  

 

name, 3 axis mill for machine, CS0 for Program Zero (shown on above picture), retract 

surface is ½ inch above the most top plane, 0.01 for tolerance. (refer Manufacturing 

Setup of part_1) 

Then click OK in Operation Setup table 

Then Done/Return in MFG SETUP menu 

 

Step 2. Auto-Drilling 

Machining > Auto Drilling 

The following window comes, click OK to accept the default Program Zero and Retract 
Plane. 
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Then Auto-Drilling table comes, you can arrange the rows by clicking Sort, (then click 

by Diameter/Hole Id/Hole Style/Status), in this case it is arranged by Diameters. 

Check From Seq for depth option, select all rows (They are highlighted after being 

selected). On right side of the table, there is a MUDF window, select center_drill.gph, 

then click <<  to apply drill strategy to these rows. 

 

 

If you make a mistake, you can select rows and then click Remove to remove the drilling 

strategy. 
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Now Check From Table for Depth Option, select first 3 rows (row #0, #1, #2), then click 

on drill_1.gph, click << to apply drill strategy to first 3 rows. 

 

 

Using the same method to apply strategy drill_2.gph to rows #3, #4, #5, apply strategy 

drill_3.gph to rows #6, #7, #8. 

 

Now click OK in the Auto Drill table. 

Then click Auto Reorder to limit tool change. 
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Click OK 

Now all the tool path have been created by using Auto-Drilling. 

You can go to NC Sequence to check the sequence created. 

 

Step 3: Play tool path 

CL Data > Output > Select One > Operation > OP_PART > Done 

 

Step 4. Create CL file and simulate with Verycut 

CL DATA > Output > Select One > Operation > OP_PART >File 

 

Check CL file only, then Done 

Give CL file name OP_PART, then click OK 

Then Done Output from PATH menu 
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Done/Return from CL Data menu 

 

Simulate tool path with Vericut: 

CL Data > NC Check > CL File  

Choose file op_part.ncl, then Open 

 

Then Done in NC VERIFICATION menu 
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5. Automatically selecting MUDF by setting feature parameters in Proe/Part 

By setting Feature Parameter ‘holestyle’ to the MUDF name without extension, the 

MUDF will be automatically assigned the hole. 

Step 1. Create a your part in Pro/E, part must has a hole feature, give name ‘autodrill_1’ 

Step 2. Set Feature Parameter 

In Part menu, choose Feature/Setup/Parameters/Feature 

Pick the hole feature, in MODEL PARAMS menu, choose Create/String 

‘Enter Parameter Name’, give: holestyle, then Enter 

‘Value for HoleStyle’, gave: the MUDF name (without extension) you want to use to 

machine this feature, in this case, give: drill_1 

Then in Part Setup menu, choose: Done 

 

Step 3. Group and pattern the feature 

(Using Pattern only, the feature parameters will not be passed to the patterned feature) 

In Part Menu, choose, Feature/Group/Create/Local Group 

Give a Group Name, then pick the hole (feature)  

Then in Select Feat menu choose: Done Select/Done 

In Group Menu, choose: Done/Reture 

Pattern the group feature to totally 4 holes 
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Step 4. In Pro/NC, create a manufacturing file using part: ‘autodrill_1.prt’ you just 

created. 

In Pro/NC, Manufacture menu choose: Machining/AutoDrilling, then in AutoDrilling 

window, you will see MUDF ‘drill_1’ is already assigned to each hole, click OK in this 

window. 

 

In the new window, click: OK   

 

 


